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11. Numerical Data Entry
Create a numerical data entry screen on which you can enter numerical data using a pop-up 
keypad.  On this screen, the keypad is not shown normally, but is shown only when necessary.

• Normal: Keypad is not shown

• When entering value: Keypad is shown.
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The keypad is displayed with the 
overlap call switch placed over the 
numerical data display part.

The keypad disappears when you 
press the ENTER key.

Contents



1. Numerical Data Entry

1-2

This chapter describes how to create a screen on which you enter values for D100 to D119.

Screen Example
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0 Dec

0 Dec 
0 Dec 
0 Dec
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SYSTEM
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0 Dec 
0 Dec

The keypad is displayed.

Press the ENTER button.
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1. Editing Overlap Library

Create a display area in the overlap library and register a keypad.  The overlap display registered 
in the overlap library can be used on any screen.  It is useful for creating a keypad mode screen or 
a menu screen.

1.1 Creating an Overlap Display Area

1. Click [Overlap Library] selected from the [Registration Item] menu.  The [Overlap Library] 
dialog is displayed.

2. Specify “0” and click [OK].  The editing screen of overlap library No. 0 is brought up.

Creating a Screen

Overlap display Max. value display

Min. value display

Entry display

Keypad

Entry icon

Overlap display formats

Type Edit Window Application

Multi-overlap Overlap library Applicable to all screens

Call-overlap

Normal Overlap Screen Applicable to the screen only where the 
normal overlap display was placed
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3. Click the [Overlap] icon or select [Parts] → [Overlap] → [Normal Overlap].  A cross-shaped 
cursor and the overlap display area are displayed on the screen.

4. Click the mouse on the screen.  The overlap display part is placed and the [Overlap] dialog 
appears.

5. Set up the [Overlap] dialog for the overlap display.
• [Main] tab window

OR

Area

Place by clicking.
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• [Style] tab window

• [Detail] tab window
Leave as default.

• [Coordinates] tab window

Item Content Setting Value

System Button Check this box if you want to add the switch function 
(move/erase) to the top left corner of the overlap display.
For more information on the operation, refer to “2.1 Displaying 
and Moving the Multi-overlap Display Part” (page 1-29).

Checked

Superimpose Check this box when using the superimpose function.
For more information on the superimpose function, refer to the 
Reference Manual (Chapter 2).

Unchecked

Item Content Setting Value

Frame Type Select the frame type of the overlap display.  This option may be 
invalid depending on the parts you select.

Tile

Color
Frame
Area

Select the frame or area color. Default

Change Part Change the part type of the overlap display. Default

Item Content Setting Value

Start X Specify the X coordinate of the overlap start point. 240

Start Y Specify the Y coordinate of the overlap start point. 100

Width Specify the width of the overlap display. 324

Height Specify the height of the overlap display. 430
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The overlap display area has been created.  Next, place the keypad.

1.2 Placing a Keypad

1. Select the overlap display.  The handles appear around the overlap display.

2. Select [Parts List] from the [Parts] menu.  The [Parts List] window opens.
3. Select [Keypad].

The size of the overlap display can be changed by dragging the handle.

Drag.

Handles
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14. Select the desired part using the [←] or [→] button or from the pull-down menu.
5. Drag the selected part onto the overlap display.  The keypad is now placed.

1.3 Entry Icon

The [Entry] icon used for setting the details of the keypad is placed at the top left corner of the 
keypad.  This icon must be always placed with the keypad.  If the [Entry] icon does not exist or the 
setting is not correct, the keypad will not work correctly.

Drag.

[Entry] icon
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♦ Checking the [Entry] Icon
1. Select the overlap display.  The handles appear around the overlap display.

2. Select the keypad.  The red handles appear.

Handles

Red handles
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13. Click the [Entry] icon at the top left corner of the keypad.  The [Entry] dialog is displayed.

The default setting is used in this chapter.  For more information on settings, refer to the 
Reference Manual (Chapter 7).

1.4 Placing Other Parts

Place the numerical data display parts for displaying the entered value, maximum and minimum 
values in the overlap display.

♦ Entry Display Part
1. Select the overlap display.  The handles appear around the overlap display.
2. Click the [Numerical Display] icon.  A cross-shaped cursor and the numerical data display part 

are displayed.

3. Click the mouse on the overlap display.  The numerical data display part is placed and the item 
dialog is brought up.

Click.

Place by clicking.
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4. Set up the [Num. Display] dialog for the placed part.
• [Main] tab window

• [Style] tab window
Specify text properties for the entered value.
You can arrange the part design by pressing the [Change Part] button.

• Operation/Alarm
When [Function: Entry Display Part] is selected, this setting is not available.

• [Detail] tab window

• [Coordinates] tab window
Specify the coordinates.

Item Content Setting Value

Digits Specify the number of digits. 5

Decimal Point Specify the number of decimal places. 1

Display Type Select the format of the numbers displayed on the screen. DEC
DEC (w/o sign)

Zero Suppress Check this box when using zero suppression. Checked
Flush Right

Function Select a function. Entry Display 
Part

Item Content Setting Value

Process Cycle Choose a process cycle. High Speed

ID Set the ID. 0

12 00012
Space

When checked (Flush Right): When unchecked:
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1♦ Max. Value Display Part/Min. Value Display Part
Follow the same procedure as the entry display part to place the maximum or minimum value 
display part.  Select [Max Value Display Part] or [Min. Value Display Part] for the function of each 
part.

1.5 Checking the ID

Check the ID of the part placed on the overlap display.
1. Click [Display Environment] from the [View] menu.  The [Display Environment] dialog is 

displayed.
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2. Check [  Display ID Number] for [Detail] and click [OK].  The ID is displayed at the bottom left 
of each part placed on the overlap display.

3. Check that the all IDs are set to “0”.  If a part having different ID from others is included, the 
keypad cannot work correctly.  Correct the ID if needed.

ID

Changing all IDs
You can change multiple IDs at one time.
1. Select the parts for which you want to set the same ID.

2. Click [Batch Change] from the right-click menu.  The [Batch Change] dialog is displayed.

3. Check [Change All - IDs] and specify the desired ID.
4. Click [OK].  The IDs for all selected parts are changed.

Right-click.
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11.6 Placing Text

Place the text for entered value/maximum value/minimum value displays.

1. Select the overlap display.  The handles appear around the overlap display.
2. Click the [Text] icon.  A cross-shaped cursor appears.
3. Click the mouse on the overlap display.  The text box and the [Text] dialog is displayed.
4. Enter your desired text.  Change the color and adjust the display position as required.

The overlap library editing has been completed.  Move back to the [Screen Edit] window.

Text

2. Text icon

1. Handles

3. Click.

4. Enter the text.
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2. Editing the Screen

On the [Screen Edit] screen, place numerical data display parts where data is written, switch parts 
to call an overlap display, and multi-overlap display parts.

2.1 Placing a Multi-Overlap Display Part

1. Select [Parts List] from the [Parts] menu.  The [Parts List] window opens.
2. Select [Entry] and [#0 3D NUM. Display].

Multi-overlap 
display part

Numerical data 
display part

Switch part
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13. Select the [Multi-overlap] icon and drag it onto the screen.  The icon is placed and the 
[Multi-overlap] dialog is brought up.

Use the default setting in this chapter.  For more information on the setting, refer to the 
Reference Manual (Chapter 2).

Place by dragging 
the icon.

The multi-overlap display part can also be placed from the [Parts] menu or Catalog View.
Example: From the [Parts] menu

1) Click [Parts] → [Overlap] → [Multi-overlap].  A cross-shaped cursor and the 
[Multi-overlap] icon are displayed.

2) Click the mouse on the screen.  The icon is placed and the [Multi-overlap] dialog is 
brought up.

Place by clicking.
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2.2 Placing a Numerical Data Display Part

1. Select [Parts List] from the [Parts] menu.  The [Parts List] window opens.
2. Select [Entry] and [#0 3D NUM. Display].

3. Select a numerical data display part and drag it onto the screen.  The numerical data display 
part is placed.

Drag.
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14. The [Num. Display] dialog is displayed.  Set each item as required.
• [Main] tab window

Specify the target memory and the function of the part.

• [Style] tab window
Set the part designing option as well as the character properties.

Item Detail Setting Value

Memory Specify the memory address of the target. D100

Data Length Choose the data length of the target memory.
Setting: 1-Word, 2-Word

1-Word

Digits Specify the number of digits of the target memory.
Setting value: 1 to 32

5

Decimal Point Specify the number of decimal places.
Setting value:

0: No decimal point
1 to 10: With decimal point (from the first to the tenth 

decimal place)

0

Display Type Select the format of numbers to be displayed on the screen. DEC
(w/o sign)

Input Type Choose the code to be used for reading the memory address. DEC

Zero Suppress Check this box when using zero suppression. Checked
Flush Right

Function Select the numerical data display function. Entry Target

Order INC Specify the order of cursor moving among multiple entry target 
parts.

0

12 00012
Space

Checked (Flush Right): Unchecked:
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• [Operation/Alarm] tab window
Set the alarm setting.

• [Detail] tab window
Leave as default.

• [Coordinates] tab window
Specify the coordinates.

Item Detail Setting Value

Alarm Check this box when using the alarm function. Checked

Min. Specify the color displayed when the data reaches its minimum or 
when it falls short of the minimum.

0
Red

Max. Specify the color displayed when the data reaches its maximum 
or when it exceeds the maximum.

50000
Blue

Word Operation For more information, refer to the Reference Manual (Chapter 5). Unchecked

Scaling
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12.3 Copying the Numerical Data Display Part

1. Select the numerical data display part.  The handles are shown around the selected part.

2. Click [Multi Copy] from the [Edit] menu or click the [Multi Copy] icon on the toolbar.  The [Multi 
Copy] dialog is displayed.

3. Set up the dialog as shown below and click [OK].  The numerical data display part is copied.

OR



1. Numerical Data Entry

1-20

4. Click [Display Environment] from the [View] menu.  The [Display Environment] dialog is 
displayed.

5. Check [  Display Memory] and click [OK].  The memory address is shown at the bottom left of 
each numerical display part.  In the following example, the addresses are set from D100 to 
D119.

Y Distance

Direction

X Distance
(100)

(5)
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16. Modify the settings for each numerical data display part.  In this example, set as shown below.

The setting for the entry target has been completed.

Main
Display Type: DEC (w/ +− sign)

Alarm
Min.: −10000
Max.: 10000

Main
Decimal Point: 1

Main
Digits: 4
Display Type: HEX
Zero Suppress: unchecked
Alarm: unchecked
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2.4 Placing an Overlap Call Switch Part

Place the invisible overlap call switch part over the numerical data display part.

1. Select [Parts List] from the [Parts] menu.  The [Parts List] window opens.
2. Select [Entry] and [#0 3D NUM. Display].

3. Drag the invisible switch part (shown with dotted frame) onto the screen.  The [Switch] dialog 
is brought up.

Drag.
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14. Check [Display Position] in the [Main] tab window of the [Switch] dialog.  In this example, [X 
Coordinate: 0] and [Y Coordinate: 0] are set, thus the [MLIB] mark is displayed at the 
coordinate of [0:0].

5. Specify the coordinate as [X Coordinate: 420] and [Y Coordinate: 160].  The “MLIB” symbol 
moves to the coordinate of [420:160].

  This symbol indicates the display position of the multi-overlap display part.
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6. Adjust the size of the switch to be placed over the numerical data display part “D100”.
7. Follow the same steps to place the switch part over the numerical data display part “D110”.

8. Specify the coordinate as [120:160] for [Display Position].  When this switch is pressed, the 
multi-overlap display placed on the left is displayed.

The display position of the “MLIB” symbol can also be specified by using the [Specify with 
Mouse] button.

1) Click the [Specify with Mouse] button.  A cross-shaped cursor and the overlap display 
box are displayed on the screen.

2) Click the mouse on the position where the box does not exceed the screen area.  The 
“MLIB” symbol moves to the position where you click the mouse.

OVLP
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12.5 Copying the Switch Part

Copy the overlap call switch part.
1. Select the part placed at the left side.  The handles are shown around the selected part.

2. Click [Multi Copy] from the [Edit] menu or click the [Multi Copy] icon on the toolbar.  The [Multi 
Copy] dialog is displayed.

3. Set up the dialog as shown below and click [OK].  The switch part is copied.

OR
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4. Adjust the size of the switch parts placed on the second column from the left.

5. Select the switch part placed on the second column from the right.  The handles are shown 
around the selected part.

6. Click [Multi Copy] from the [Edit] menu or click the [Multi Copy] icon on the toolbar.  The [Multi 
Copy] dialog is displayed.

Adjust.

OR
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17. Set up the dialog as shown below and click [OK].  The switch parts are copied.

8. Adjust the size of the switch parts placed on the extreme right.

The switch parts have been placed.

Adjust.
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2.6 Placing Text

Place text showing the screen title and the memory number.

1. Click the [Text] icon.  A cross-shaped cursor appears.
2. Click the mouse on the screen.  The text box and the [Text] dialog are displayed.
3. Enter your desired text.  Change the color and adjust the display position as required.

The screen editing has been completed.  Transfer the screen data and check the operation.

Text

1. Text

2. Click.

4. Entry

3. Entry text.
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1
1. Memory Allocation

The following memory addresses are used in this example.

2. Operation

2.1 Displaying and Moving the Multi-overlap Display Part

1. Press the numerical data display part on the screen.  The overlap display appears and the 
cursor is displayed on the numerical data display part.

2. Press the top left corner of the overlap display.  The overlap frame blinks.

Operation Check

Memory Memory Contents
D100 to 119 Numerical data display (entry target)
$u16330 * Entry mode (command memory)

$u16340 * Entry mode (information output memory)/multi-overlap (information output 
memory)

* When controlling the entry mode or using information output memory, use different address 
from the above.

Blip!

The overlap 
frame blinks.
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3. Touch the point where you want to move the overlap display with a finger.  The overlap display 
is moved.

4. The overlap display disappears when you double-click on the top left corner of the overlap 
display.

Touch the point where you want to move 
the overlap display with a finger.

The overlap display can be moved or cleared only when [System Button] is checked in the 
[Overlap] dialog. 
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12.2 Entering Numerical Data

1. Press the numerical data display part of “D100”.  The overlap display appears on the right side 
and the numerical data for “D100” becomes highlighted.

2. Press [3] and [3] on the keypad.  “33” is indicated for “Key-in.”

Blip!

The current value 
entered in “D100” is 
displayed in the “Key-in” 
area.

The alarm setting is made 
for “D100”, thus the 
maximum and minimum 
value is displayed.

When the alarm setting is made for the entry target, [Max.] and [Min.] are displayed on the 
overlap display.  When you enter the value out of this range, the ENTER key will not work.

← “33” is displayed for “Key-in”.
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3. Press the ENTER (or CR) key.  The overlap display disappears and “33” is displayed for 
“D100”.  At this time, you can check that the “33” is written to the address D100 in the PLC.

Other values can be written by following the same steps.

D100
D101 
D102 
D103

D117 
D118 
D119

33 Dec
0 Dec 
 0 Dec 
0 Dec

0 Dec 
0 Dec 
0 Dec

F1

F2

F3

F4

F5

F6

F7

SYSTEM

POWER

PLC

When entering a negative value such as “−200”:
Press the [2], [0], [0], [+/−] and [ENTER] (or CR) keys in order.
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The following describes possible keypad problems on the multi-overlap display and measures.

• The cursor is displayed even though the overlap is not called.
- The entry mode using the [Entry] dialog has been set on the screen editing window.

The entry mode must be set up on the same library as the keypad (= on the overlap 
library).  Clear the setting of the [Entry] dialog set for the screen.

• The overlap display does not disappear though the [ENTER] key on the overlap display is 
pressed.

- The possible causes are:
1) The numerical data display part and the overlap call switch are not placed on the same 

position.
The overlap call switch should be placed over the numerical data display part (entry 
target).

2) The entry target is placed on multiple switches which calls an overlap.
When the entry target is placed, not on one switch, but on the multiple switches, the 
overlap may not disappear when you press the [ENTER] key.

3) The system memory address $s76 has the value except for “0”.
The AUTO OFF function of keypad (when you press the [ENTER] key, the overlap 
display disappears) is prohibited when the value except for “0” is specified in the 
system memory address $s76.

Questions and Answers

1234

1234

1234

1234

1234

1234

1234

1234

1234

1234

When the switch which is registered to 
this screen later is pressed, the overlap 
display does not disappear even when 
you press the [ENTER] key because two 
switches are placed over one numerical 
data display part.

OK No Good

Data 6

Data 7

Data 8

Data 9

Data 10

Data 1

Data 2

Data 3

Data 4

Data 5




